|
Поделиться

Ошибка настройки расширения

После обновления произошла ошибка настройки расширения

Если требуется помощь с движком версии 3.1, спросите её здесь.

Сообщение Chip » 17.01.17 01:07

Всем привет)Я новичок, так что не пинайте сильно если что не так) А если кратко изначально, то после обновления phpbb c версии 3.1.9 на 3.1.10 произошла ошибка настройки расширения. Свою ошибку понял поздно. До обновления мне нужно было поотключать и удалить все установленные моды. Очистка кэша не помогла. Посоветуйте ГУРУ что мне нужно предпринять! Вот скрины:
Вложения
2017-01-17_000658.png
2017-01-17_000638.png
Chip
 
Сообщения: 5
Зарегистрирован: 17.01.17 00:59

Сообщение Shredder » 17.01.17 16:04

Chip писал(а):c версии 3.1.9 на 3.1.10 произошла ошибка настройки расширения. Свою ошибку понял поздно. До обновления мне нужно было поотключать и удалить все установленные моды.

Для обновления с минорных версий не нужно ничего отключать и удалять.

Не совсем понял, что вы сделали. Удалили расширения с сервера, не отключив их в админке? Или наоборот, ничего не удаляли и не отключали, а после обновления "неожиданно" вылезла ошибка? И на какой конкретно странице она возникает? Опишите всю последовательность своих действий.
Выполняю работы по phpBB3 на заказ. Пишите в личку или на почту.
Бесплатная поддержка - только в темах.
Shredder
Администратор
 
Сообщения: 884
Зарегистрирован: 22.08.13 09:05

Сообщение Chip » 17.01.17 17:02

Shredder писал(а): Или наоборот, ничего не удаляли и не отключали, а после обновления "неожиданно" вылезла ошибка?

Да, верно, я ничего не делал и после обновления с одной версии на другую произошла такая ошибка.
Shredder писал(а): И на какой конкретно странице она возникает?

Эта ошибка, на скрине под №1, возникает при вхождении на вкладку НАСТРОЙКА РАСШИРЕНИЙ в админке, а на втором скрине отображаются отсутствующие и не удаляемые расширения во вкладке ПЕРСОНАЛИЗАЦИЯ - УПРАВЛЕНИЕ РАСШИРЕНИЯМИ.
Chip
 
Сообщения: 5
Зарегистрирован: 17.01.17 00:59

Сообщение Sumanai » 17.01.17 17:13

Chip писал(а):а на втором скрине отображаются отсутствующие и не удаляемые расширения во вкладке ПЕРСОНАЛИЗАЦИЯ - УПРАВЛЕНИЕ РАСШИРЕНИЯМИ.

Ну так залейте их файлы обратно и удалите, если они вам не нужны. Первая ошибка так же связана с тем, что удалены файлы расширения без его отключения в админке.
Судя по числу расширений без файлов вы неправильно следовали инструкции по обновлению и удалили каталог /ext/. Верните его из резервной копии, и всё наладится.
Sumanai
 
Сообщения: 28
Зарегистрирован: 05.12.15 20:47

Сообщение Chip » 17.01.17 18:29

Спасибо всем за помощь) Всё заколосилось. Вернул из бэкапа всю папку и теперь можно уже всё исправить, так как эти странички открываются)
Sumanai писал(а):удалили каталог /ext/

После обновления, получается, эта папка была удалена без моего вмешательства)
Chip
 
Сообщения: 5
Зарегистрирован: 17.01.17 00:59

Сообщение Shredder » 17.01.17 19:17

Chip писал(а):После обновления, получается, эта папка была удалена без моего вмешательства)

Довольно странно. Такого вроде не должно быть...

Глюк движка?
Выполняю работы по phpBB3 на заказ. Пишите в личку или на почту.
Бесплатная поддержка - только в темах.
Shredder
Администратор
 
Сообщения: 884
Зарегистрирован: 22.08.13 09:05

Сообщение Chip » 17.01.17 20:19

Shredder писал(а):Довольно странно. Такого вроде не должно быть...

Хмм..даже и не знаю что Вам ответить. Кстати каталог /EXT/ был пустой.
Возможно всё дело в том, что в моём случае обновление идёт из оболочки DSM 6.0, у меня Synology 216play, и на нём установлен мой форум. С этими процессами я сталкиваюсь впервые, касательно самого обновления и как оно проходит,так и с самим форумом, который я на нём развернул, на чём то нужно учиться) Хорошо, что сделал каждодневный бэкап форума.
Ещё раз спасибо за нужный, быстрый и своевременный совет. Буду обращаться, если позволите)
Chip
 
Сообщения: 5
Зарегистрирован: 17.01.17 00:59

Сообщение Shredder » 17.01.17 20:36

Обращайтесь ;)

Chip писал(а): Кстати каталог /EXT/ был пустой.

Опустел после обновления?

Chip писал(а):после обновления phpbb c версии 3.1.9 на 3.1.10

А точно обновляли с 3.1.9, а не с 3.0.9, например?
Выполняю работы по phpBB3 на заказ. Пишите в личку или на почту.
Бесплатная поддержка - только в темах.
Shredder
Администратор
 
Сообщения: 884
Зарегистрирован: 22.08.13 09:05

Сообщение Chip » 17.01.17 22:06

Shredder писал(а):Опустел после обновления?

Опустел действительно после обновления.
Shredder писал(а):А точно обновляли с 3.1.9, а не с 3.0.9, например?

С 3.1.9 обновлял на 3.1.10. Свой DS 216 купил 3 месяца назад и через месяцок установил PHPBB, а в это время последней версией для моего SYNOLOGY была именно 3.1.9, да и набор расширений подбирал именно на 3.1.9. Вот и сейчас якобы имеется насколько я знаю 3.2.0, хотя для моего 3.1.10 последняя, которая и обновилась недавно. Запаздывает SYNOLOGY с адаптацией продукта)
Вложения
2017-01-17_210120.png
Chip
 
Сообщения: 5
Зарегистрирован: 17.01.17 00:59


Вернуться в Поддержка phpBB 3.1.x

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

cron